Cards loading extemely slowly in deckbuilder

Bug
  • Erodos's Avatar Crossroads Historian 935 1017 Posts Joined 05/29/2019
    Posted 2 months, 1 week ago

    I have been running into the issue that the card library seems to be loading extremely slowly in the Hearthstone deckbuilder, like multiple minutes slow. I am not sure how long this issue has existed, but I remember it not being there during the previous reveal season. I have experienced this issue in both Firefox and Edge on Windows 10.

    3
  • Fluxflashor's Avatar Administrator 1895 2746 Posts Joined 10/19/2018
    Posted 2 months, 1 week ago

    I'm aiming to get an update in this weekend to change our deckbuilder back to older functionality. We made a change that overall should have only sped-up the deckbuilder but unfortunately this ended up being not the case. It's certainly a shame because a lot of time was spent on it but it looks like some machines and browsers just aren't a fan of indexeddb support, despite being a web standard and working across the board with the exception of people on Firefox Permanent Private Browsing Mode, which is a very niche group of people using it, which is already a niche of users using Firefox.

    So yeah, aiming for something late Sunday more than likely. If not Sunday, definitely Monday, the day before Castle Nathria launches.

    Founder, Out of Cards

    Follow me on Twitch and Twitter.
    If you are planning on playing WoW on US realms, consider using my recruit link =)

    3
  • Erodos's Avatar Crossroads Historian 935 1017 Posts Joined 05/29/2019
    Posted 1 month, 2 weeks ago

    It's still loading very slowly for me. Cache issue? Or was it not fixed yet?

    1
  • frosthearth's Avatar 645 581 Posts Joined 03/18/2019
    Posted 1 month, 2 weeks ago

    I have the same issue on my google chrome browser. I first noticed it somewhere before Nathria launch.

    0
  • Leave a Comment

    You must be signed in to leave a comment. Sign in here.